西姆极客 建站 linux常见问题

linux常见问题

安装包问题

Please install the gcc make perl packages…

CentOS_7_64 GNOME环境下(含开发工具),安装某些程序包时提示缺少gcc make perl 包。

原因:缺少前置依赖。
解决方法:安装gcc,命令行如下,安装装过程中会出现两次提示,均输入y确认继续。

yum install gcc perl make

您需要 root 权限执行此命令。

解决方法:输入su后回车键,再输入密码,切换到管理员权限。

Another app is currently holding the yum lock; waiting for it to exit…  process ID : 17638

原因:需要更新的程序包正在被占用,需要关闭进程(ID 17638)
解决方法:强行关闭进程,命令行如下。

kill -9 17638

Please install the Linux kernel “header” files matching the current kernel for…

原因:缺少前置依赖。
解决方法:安装 kernel-devel,执行命令行如下。

yum install kernel-devel

如果安装最新的kernel-devel之后还是提示这个错误,可能是因为kernel当前版本与kernel-devel的版本不符合,此时有两个选择,第一个是更新kernel版本 yum install kernel 后重启使用相同版本的kernel即可(安装新的kernel后可以参考我的另一篇文章清除老旧的内核)。另一个选择是寻找符合旧kernel版本的kernel-devel安装包。

如何安装本地gitlab.rpm

cd 到目标所在的文件目录

yum localinstall gitlab.rpm

gitlab-ctl reconfigure

环境配置

安装完centos minimal(最小化安装)无法联网问题

原因:默认没有启动网络功能。
解决方法:
用cd命令进入 /etc/sysconfig/network-script/文件夹

用ls命令查看这个目录下的网络配置文件,我这里默认是ifcfg-enp0s3

用vi命令编辑配置文件的中的项目,ONBOOT=yes

重启网络服务 service network restart,ping以下外网

标签:

发表评论

电子邮件地址不会被公开。 必填项已用*标注

16 − 12 =

Scroll Up